fredag, juli 27, 2007

Should JRuby support 1.4.2?

Right now we're trying to decide if JRuby should upgrade from Java 1.4.2 to Java 5. There are some compelling reasons for this, but I'm not a 100% sure it's a good idea. Any comments from my readers?

In practical terms, this will mean that JRuby 1.0 will continue to be supported on 1.4.2, but new development will only work on Java 5 or higher. There is talk about using retrotranslator for handling 1.4.2 compatibility in later versions.

So. Please, comments and opinions!

20 kommentarer:

Marcell Manfrin sa...

I think it is a good idea because it will easy contributions as Java5 is simpler to read/write the 1.4.2.

fizx sa...

I'd rather see a faster development cycle than backwards compatibility.

Anonym sa...

I for one am stuck on Java 1.4.2 and Tomcat 5.0.x. Pathetic. But would like to try deploying a Rails app w/ JRuby . . .

MC sa...
Den här kommentaren har tagits bort av skribenten.
MC sa...

Websphere 6 and Weblogic 9 (yes, outdated, but still very much in production use) are both 1.4.x-bound.

Eliminating the 2 largest commercial app-servers out there from using JRuby seems an imprudent decision.

Daniel Spiewak sa...

Personally, I vote for cutting ties with 1.4. The advantages of using Java 5 features and enhancements would be well worth it imho.

Jackson sa...

I for one know I will be deploying with 5.

Anonym sa...

Though point on WebSphere 6 is reasonable I think that those deploying JRuby apps are kind of cutting edge people in terms of state of mind. So you'd be better developing it faster with Java 5. World won't stick with 1.4 for too long.

Eclipse guys are planning to move to Java 5, this seems to be a huge trend in the Java community.

Anonym sa...

I think the language constructs introduced in Java 5 are worth it to switch over. Even if a lot of stuff is running on 1.4.2 new stuff is going to be developed on Java 5.

toby sa...

Ola,
In my experince, if you tell others to use retrotranslator, they are going to complaint that it's slow, and this is even more pertinent in an interpreter. I am in agreement with the others here. Ditch 1.4. I think people who are willing to use jruby will most likely be willing to upgrade to 1.5 if not already using it.

Christopher sa...

People that won't/can't upgrade their jvm, but will/can deploy production code in JRuby? I really don't see that being a large group.

mortench sa...

Java 1.5+ support only makes perfect sense! There are so many advantages of building on the Java 1.5 platform instead of old 1.4

jesper sa...

Ola,
I think for a lot of users one of the most compelling aspects of JRuby is it's ability to sneak Ruby into the enterprise. If you decide to ditch 1.4, many enterprises will not be able to run JRuby (and Rails) on their existing infrastructure - and these guys don't just upgrade.
Besides from Websphere 6 and Weblogic 9 also Oracle Application Server 10g is using 1.4.2.
For now, the cutting edge shops are running CRuby/Mongrel and in the enterprise shops we can sneak in a little magic with JRuby. So for now, please stay on 1.4.

Lori M Olson sa...

I agree with Jesper. The "enterprise user" is more constrainted than most developers, but that same user is one of the primary target audiences of JRuby. Don't abandon them.

Anonym sa...

One minor note, starting with 9.0 WebLogic is on JDK 5.0 and 5.0 only (no 1.4 support listed). In fact many of the features in this version are heavily annotation-based.

Windows

Linux

So one of the major app server vendors is up to that level.

tn sa...

Now that there -is- a stable release of JRuby (1.0), users who want to stay on JKD 1.4 have a version they can use (to "sneak" Ruby into the enterprise). For new development, please use JDK 5. It's not just about language convenience - it opens up a bunch of new APIs you can use (concurrency, file permissions etc.).

luposlip sa...

I agree with jesper and others. Most enterprise users are still bound to 1.4.x.

Personally I'm developing for SAP (NetWeaver), and even though SAP has made a certified server running Java 5, it will take many years for their customers to upgrade.

I guess the same goes for customers of application server from other vendors.

Anonym sa...

Improve JRuby's speed. Then it may become an attractive Ruby VM.

Focus on the present and future, not the past.

Ben sa...

I think you could benefit greatly by moving on, however you're going to be leaving many enterprises in the dust.

A lot of us are still on Websphere 5.1, which is 1.4.

I'm not saying I think you should hold back for that, just bear it in mind.

Brian Ehmann sa...

I agree with Fizx:

"I'd rather see a faster development cycle than backwards compatibility."

Granted this will make bringing JRuby > 1.0 into my work environment a little more difficult since my employer is still stuck on 1.4.2 (for sad reasons). But when I consider the reasons why you would want to migrate to Java 5, I can not help but hope that you do.

java_5_vote += 1